The Haiku/BeOS Tip Server
Tips and tricks for Haiku/BeOS users

Queries not working within Tracker

Contributed by: Axel Dörfler
This tip is valid for: Both BeOS and Haiku

I recently encountered some strange problems with BeOS: all of a sudden, all of my standard query windows were empty – no new mail, no messages to be answered or to look at any longer. I was frightened.

I made some checks, but the indices seemed to be okay – I tried queries from a Terminal (using the query command), and they worked as expected.

Tracker adds a query for BEOS:TYPE to almost every query, but there is no index for this attribute on a standard system, which is perfectly okay since there are some other (indexed) attributes in the query as well.

Some stupid application I tried recently must have created an index for BEOS:TYPE but of course, no files were listed in there yet, so Tracker could no longer find anything.

Once the problem is revealed, the solution is often very simple:

rmindex BEOS:TYPE

You can use lsindex to get a list of all indices on the current volume – try the -l option to get more information about the indices.

Posted in Tracker & Deskbar


(comments are closed).